Uh oh, power fades to black

Urgh, well I had a fun few weeks with everything running well and then things started to get weird. On power up things usually look fine, with led power cycle on boot up and flashing led to indicate no sample. All good so far. Then I start noticing my led intensity is dimming and then flashing led goes solid and a few seconds later everything fades to black. First time this happened it was case-less with a few wires like power dangling around, so I can't be sure if something flopped onto something else. Hope not.

I also noticed that the regulator was really hot. After that I checked the power supply and noticed it was set to 12v (it's a dodgy multi volt 1000mA type) and after testing with a multimeter, noticed it read around 13.5v. So, I set that to 9v and started thinking maybe I fried something. I'm at the point where I swapped out some simple stuff, such as the regulator, the 330uf capacitor and the DC input connector but no different. I've also tried a different power supply and no luck, still the same issue.

As far as I can tell, everything seems like it's functional while it's on, as I can load a sample up and all the lights look fine, but haven't had it stay on long enough to see if it's playing ok.

So where to next? Any ideas really appreciated, as I'm fresh out.


  • the voltage regulator should control voltage levels to the components , if it fails it shuts off current flow 

    after that excessive heat usually means too much current draw some where in circuit , I'd be on look out for a crossover  solder splat....get a magnifying glass a bright light and look slowly and carefully
  • Ok, so after a lot of careful looking and some methodical resoldering just to be sure, I've eliminated any uncertainties about connections. Fairly confident about bad connections and splats but can probably never be completely sure.

    Plugged it in again and same deal. This time though I noticed that IC7 and the regulator are getting about as hot as each other.

    One thing I nearly forgot about was that I had a try uploading the @scragz bootloader but it failed so I just moved on and thought I'd get back to it later.

    So after a little digging I found this post:


    I'm now wondering if I've fried IC7 by trying the bootloader. While the symptoms are a bit different to this post, is it possible? Should I look at replacing IC7 based on heat alone?
  • **EDIT** sorry all, I obviously need glasses. After a double check its IC5 that's really hot not IC7. I guess that probably changes things a bit.
  • Although it's possible to break the input op amp with bad luck and a hot bootloader, it's probably not possible to break the RAM (IC5).

    Try looking at the voltage at the supply pin for IC5.  Compare it to the output of the 5v regulator, and the power pins on the other ICs on the board.
    If you are careful, you can tell if there's a voltage drop through the traces at high currents like the ones you probably have.

    If the VCC pin on the RAM is lower that the other pins, then that chip is pulling more current than it should (verifying what you're seeing with the hot IC).

    I'm sure you already did this, but make sure all your solder connections on or under IC5 are OK.  Also make sure R38 and R39 are the correct values and you're not powering the chip from one of those.
    See if you can record any kind of sample, no matter how briefly.

    If you ARE SURE that IC5 is pulling too much current, carefully desolder or clip the VCC pin.  Try to do it such that you can repair it with a jumper wire if you are wrong.
    If your heat problem goes away, you have a bad IC.  NOTE -- don't try and sample when you're doing this, the latches will try to power the RAM through the output lines.

    Good luck and sorry you're having trouble.
  • Thanks for the pointers Todd.

    I had a quick go to get voltages but found many vccs were showing up as OL until the leds started fading then voltages started dropping. I'm a real fresh noob at this, but I'm guessing it's like an inbuilt ic protection mechanism that's at play here?

    I'll have a proper try tonight and let you know what I see.
  • So VCC should show up as _about_ 5v everywhere.  I'd expect a shorted IC to have a _slightly_ lower VCC than the rest.  Tenths of a volt or less.
    Perhaps you need to change the range on your meter?  Is it set to volts DC?

    The fading you see has to do with the regulator going into thermal shutdown.  It's a symptom of a short somewhere.

    Good luck!

  • Ok, a little progress. I found the power input jack was crappy so removed it from the equation and managed to get voltage readings more like what I was expecting. It's kinda tricky since once things start getting hot the voltage starts to drop, so I've only got a short time to try and get the numbers before everything starts looking like a problem.

    Here are the voltages:
    IC1 (pin10) 4.98V
    IC2 (pin20) 5V
    IC3 (pin20) 5V
    IC4 (pin20) 5V
    IC5 (pin32) 4.94V (I'm thinking this is the problem)
    IC6 (pin3) 5V
    IC7 (pin4) 5V
    IC8 (pin20) 4.98V
    IC9 (pin16) 5V
    IC10 (pin 20) 4.98V
    IC12 (pin8) 5V

    R38 is 200k 1%
    R39 is 470ohm 5%
    ...so both seem ok.

    So, getting hopeful that IC5 might be the issue, I desoldered pin 32 but still had continuity to it's pad. Then I carefully clipped it and still had continuity to it's pad (?). Powered up and IC5 is still really hot.

    Not sure but this doesn't seem like what I should be expecting. I just figured there'd be no connection for the RAM once the Vcc was disconnected. Is this helpful?
  • Yep, helpful.  Thanks.

    Since there are lots of address and data pins on the RAM chip, there are lots of other "connections" to Vcc through them.  If Vcc isn't connected and the chip is still getting hot, you may have what's called "bus contention".
    Since data comes in and out of the RAM chip, those data pins are sometimes inputs and sometimes outputs.  If the data pins for the RAM are made outputs at the same time the the data bus is driven by something (the AVR I believe) then something is going to get hot.
    You could also have a data pin shorted to ground somewhere and driven high or v/v.

    Make sure your WE/OE pins are doing what they're supposed to on the RAM chip (or at least aren't shorted).

    The chip itself could also just be damaged and drawing current through an input pin.

    At this point the simplest thing to do would be to swap the RAM chip.  They're not expensive so buy two.  Consider buying a socket for that chip too so you don't have to do this again.

    Good luck and sorry you're having such a hard time.
  • Thanks Todd. Parts are on their way. Hopefully in the home stretch now. I'll let you know how I go.
  • Well I'm moving in the right direction. Replaced RAM and lights stay on, yeehah! RAM is now cool too. It'd be nice to be saying it's all done and dusted but here's a complication.

    Playing samples once loaded into RAM and they sound like a dalek talking on the phone! Still recognisable but distorted, a bit flangey and a bit garbled. Playing straight from CF card everything sounds fine.

    I've checked the sum mode to make sure I'm not doing funny math and double checked audio connections even though I'm sure that's not the issue. Regulator is still a little warm but nothing like before.

    Anybody know what's happening?
  • A further check and it looks like my problems go deeper. The scrambly playback is on both A and B, playback good on card mode as mentioned, but it seems I'm also back to having midi issues.

    Even though I have the channels in default setup (1,2,3) card reader mode previews through note messages on 1, while knob cc's for bank A also respond on 1?! No note response for bank A or B. What's this then, a CPU thing?

    This is starting to get me down. Not sure where to head next. My noob butt is in a sling with this, so any ideas appreciated.
  • Btw, all chips feel cool to touch but regulator is still running warm. I can touch it but only just. Might have even gone into shutdown on testing once but not completely sure.

    Also fwiw, there is no led response for midi notes either. Tried all midi channels on controller just to make sure too.
  • So one problem at a time.  Good job so far.
    You had a broken RAM chip, sounds like.  Let's fix the "scrambly" problem first.

    Since we know your RAM was broken, and we know streaming from the SD card is OK, we know a couple of things:
    The DAC works OK.
    The clock works OK.

    Double check your soldering.  If you're sure it's good, most likely whatever damaged the RAM also damaged a DATA or ADDRESS line, post latch.  Since streaming works, we know the DATA lines are OK.  This probably means something is wrong with an address latch, which are IC2 and IC3.

    I assume test mode works OK?

    Do you have a "ghetto scope"?  You can and should try and see if all the pins are toggling (on data AND address, though suspect address first.  You can test DATA with a multimeter and test mode, too.

  • Test mode gives me a pot controlled sine wave, buttons that correspond to leds but a little weirdness in the encoder, which seems to count 1 & 2 twice before moving on to 3. There are a couple of other jitters too but must admit my binary is pretty rough. I can probably work it out if it's critical.

    I have a ghetto scope so will probe around and repot back.
  • Even though I planned to pull out the ghetto scope I got a bit impulsive and grabbed a couple of octo latches to swap out IC2 & IC3 and turned out IC2 was the one! So sound is back on!!

    Now lastly, time to sort my midi and get back to making music. I'm thinking I should start back at opto pin6 and atmega pin 14 with the ghetto scope to see if I'm getting midi.

    Seem like a plan?
  • Yep, seems like a plan.  Remember the MIDI mods listed here too (the additional resistor).
    Good job getting that repair done!
  • MIDI is now sorted! Turns out my channel changes weren't saving. I think the manual might have a typo here, as for me S3 saves channels to memory, not S2.

    So once again I'm back in business!! After all this drama I'm pretty convinced it all happened coz I hadn't cased it up and the power connector hit the regulated side of the board and fried a few things.

    Thanks to everyone for their help on this. It'd be in the bin if I was trying to fix this myself!
  • You DID fix it yourself.  Nice job.
    As the guy who designed this, basically every time it breaks it's _a little_ my fault.  It's worth it to see how it breaks and why, and how people deal with that, etc.
    I think it's safe to say that many people with a WTPA as broken as yours would have given up.  Especially without a fancy workbench.  So you should be proud.

    Let us know what you get up to with your newly-fixed WTPA.

    And thanks for the heads up with the typo.  I'll check the manual.

Sign In or Register to comment.