Audio In mysteriously started cutting out when VR1 greater than 5kΩ

Everything was fine for a week or two, totally functioning, recording, flashing my new firmwares and everything. Ever since last night, out of nowhere, the audio in hasn't been working. Today I got it to sort of work again as long as VR1 is turned waaay down (at like 5-10%, appx 4.8kΩ). Turning it further and it quickly starts getting quieter and then cuts out completely. At first I thought the pot was faulty but it seems to measure fine from 0 to 88k when turned all the way. I resoldered VR1 then double/triple/quadruple checked every connection, trimmed everything up just to make sure there weren't any shorts. It samples okay as long as that pot is down but I don't think it is loud enough to read the firmware audio (trying to do that LEDs 0,1,7 light up and then it boots after a couple seconds). Everything in the self test works fine.

Any ideas??? I'm not too savvy with the troubleshooting and I don't really have any clue what could be causing it to work fine except when that pot is turned up, especially when it was functioning so well up until last night. SD card and MIDI are all cool.


  • I am also having this same problem being audio in only working very low any higher cuts out, as well as overdub destroying the sample- entirely. Any help of what might be wrong would gladly be appreciated.
  • Interesting.
    @scragz, sorry to get back so slowly on this.

    Can you tell me the signal sources you two are using?

    As you vary VR1, does the signal get distorted before it gets quiet?

    Does it matter what level of the signal you are sending?

    Do either of you have a multimeter?  If so, can you set up your WTPA2 such that it exhibits this problem and measure the DC voltage at pins 1, 3, 5, 6, and 7 of IC7?
    Do this with no audio, working audio, and "cut out" audio and let me know what you read.

    If you have an oscilloscope send traces at those spots.  I'm guessing you might not, so if you can generate a low frequency audio sine wave (like 60Hz or so) then do so, and read the AC voltages in the same spots on the board.

    I have an idea of what it might be but I haven't seen this on any of my units, and so don't want to guess until I have numbers.

    Best, and sorry!

  • The signal source Ive been using is a portable cd player, with some ripped cd's.

    VR1 goes silent (no distorted signal) past 2.5k 

    Level of the signal source does not matter.

    no audio       1- .02v  3- .011v  5- 2.44v   6- 2.45v  7- 4.3v 
    work. aud.1-.03-.05v  3- .011v  5- 2.44v   6- 2.45v  7-4.78

    when overdub doesnt work the levels are the same as when there is working audio.

    thanks for trying to help me figure this out.
  • OK.  So the problem is that your input stage biases are not correct.
    Did this _ever_ work right for you and then stop or has it always been messed up?  This may be telling.
    Refer to the page 2 schematic here:

    C13 AC couples your audio input signal, blocking any DC contribution from your signal source.  A bias voltage of VCC/2 (about 2.5v) is applied to pin 3 of IC7 via R12.  This moves the audio input signal up by 2.5 so it is in the middle of the range of the ADC.
    You can see from you tests that pin 3 (the input) is close to ground -- it should be biased up to about 2.5v (like pin 5 is).
    Since the bias voltage is wrong, the second stage of the amplifier is amplifying the DC difference and pinching off your signal.

    Since the voltage at pin 5 is close to correct, the problem is likely near pin 3 of IC7.
    Check resistance to ground at this pin.

    Check it with your signal source plugged in (but not sending) and not plugged in.

    The following problems are most likely:

    1.) R12 is open or soldered poorly and there is no bias path at all
    2.) C13 is short (solder blob, maybe?)
    3.) IC7 is damaged

    Try checking resistance to ground at pin 3 and check resistance across C13.
    If nothing is obvious there, try replacing IC7.  You may want to socket it if you haven't already.
    If you do socket it, you can try an LM324 or any old generic quad op amp as a test op amp.

    Let me know!
    @scragz, does this line up with your problem?
  • edited March 2015
    Ok, new problem! I tried resoldering R12 and C13 and now I have no audio in whatsoever. It was either that or, in measuring everything I accidentally shorted pins 9 and 10 together and the thing rebooted. So maybe the chip isn't happy?

    I'm not totally sure I am multimetering right. The manual says a good ground is the chasis of VR5? Well, assuming I am doing it correctly, I have the same readings with or without audio in:
    1: 2.5v
    3: 2.5v
    5: 2.4v
    6: 2.4v
    7: 2.4v

    As for the initial problem, it worked fine for a couple weeks, then started cutting out, and now no audio in at all. There wasn't distortion when it did cut out.

    All the solder joints in the nearby components look fine. Should I cut out IC7 and socket in a LM324N? Anything else I should check first?

    Thanks a bunch for your help!
  • Those DC voltages are correct.  It's possible your op amp is busted but it seems more likely that audio isn't getting to pin 3.
    And if the pot bodies are soldered down, they're a good ground.  The tab of the voltage regulator is too.

    1.)  Check the resistance of the "audio in" pin to ground.
    2.)  Check the resistance of pin 3 to ground (it should be high).
    3.)  Check for shorts at "Aud" near the voltage regulator
    4.)  Make sure your audio jacks aren't doing something weird like switching the wrong way.

    5.)  Check resistance across C13 (should be very high)
    6.)  Check resistance across R12 (should be 200k).

    You could try and "inject" a signal at pin 6 of IC7 using a signal source in series with a capacitor.  May sound messed up but you should get audio.

    Let me know and good luck!

  • I replaced ic7 and that fixed it. Hopefully that might be the answer for you too scragz. good luck, and thanks.
  • Interesting! So the IC got damaged somehow. Let me pull up the schematic and ponder.
  • ACTUALLY.  I'm not that surprised, I guess, looking at the schematics.
    IC3 has no real input protection, which is stupid on my part.  That circuit got carried over from WTPA1 which was made when I was still kind of a dumbass.  More than now even.

    A stiff signal greater than 5Vpp can pretty easily damage the input stage, since there's nothing there to limit current into pin 3, and nothing there to clamp the excursion except pin 3 itself.

    It would probably be pretty easy to do this with the headphone out of some devices.

    A FIX:
    Insert a series resistor of 10k or so.  I probably didn't do that initially because I was being a big whiny baby about noise, but old, surly Todd knows that the microvolts of noise you add by doing that are worth the NOT BREAKING and kind of don't matter at all on an 8-bit sampler.
    Best place would be between the junction of R12/C13 and pin 3 of IC7.
    An easier place would be between the inside leg of C13 (lift that leg and solder it, flying in the air, to a 10k resistor) and R12 (solder the other end of the flying 10k to either the inside pin of R12 or the pad of pin 3).
    The series 10k will limit current into pin 3 at any reasonable input voltage.

    FWIW, the audio bootloader pretty much encourages you to break your WTPA2 that way, since it's all like PLUG IN YOUR HEADPHONE JACK OR WHATEVER AND CRANK IT.

    On my desk I use a little mixing board for my computer, so I was dealing with line out, which of course worked fine.

    My bad.
    @scragz, this explains a lot.

    @miker Thanks for doing that repair.

Sign In or Register to comment.