Stuck...No MIDI...what next

Well I am hardly on a roll here...short story, everything works but still NO MIDI control , MIDI signal gets to pins 2 and 3 of the opto, but nothing comes out pin 6 and on to pin 14 of the main chip.

I have quadruple checked all the wires and solders between i/o board and the main board, no solder bridges, all good solders and the fact that MIDI gets to the opto seems to support that idea that the wiring is OK, I have looked under the board and the socket for the opto is cleanly in , no solder bridges...I get voltage to the chip at pin 5,  pin 14 of the main chip idles at 5volts 

AFAIK there are no shorts on the opto, and to be sure I'm not using a fried one I installed a new one in the socket , 

from there I verified I have a good MIDI signal being sent that I can see on the scope, I have the MIDI channels set to 0 and 1 correctly, I am sending from MIDI ch1 and 2 from the computer,(which corresponds to wtpa 0 and 1)  notes sent are  centered around c1 to c3.    I  see the indicator lights on the MIDI interface, I can trace the signal all the way up to the input side of the opto , it starts and stops when MIDI starts and stops ....just seems that that is the end of the line....

So what are my options now. without MIDI play it is just a fun noise box, (sample,tweek, sample, tweek, yada yada ) however my idea for it was to capture and keep interesting samples on the SD and then play them back with a MIDI sequencer and then cave-manthe knobs for "the party" 

Can Todd put it on his bench to see what's up? I'm willing to pay his normal bench rate and shipping for that.  I've tried everything to my knowledge (which admittedly is limited) 


  • Careful what you ask for! My bench rate is really expensive :-)

    Maybe somebody else on the forum wants to take you up on this? Could be a good learning experience. If that doesn't pan out, let me know and we'll figure something out.
  • MIDI not working sytematic approach - can you see something wrong here??????

    Well for the life of me I don't why its not working 
    I made sure I was getting a good MIDI signal by plugging another synth into the MIDI cable I;m using and it played just fine, so that possibility is elliminated, double checked MIDI channels on the WTPA2 set to 0,1 , 2 (default) , set the MIDI on the computer to channel 1 = and NADA 

    so let's get down to basics , I pulled the opto out and checked the following 

    wtpa2 diagnostics using Fluke multimeter 
    Look for a short to ground
    with opto chip removed test continuity from ground pin of 7805 volt regulator to to following
    pin1 = inf ohms
    pin2= inf ohms
    pin3= inf ohms
    pin4= inf ohms
    pin5 = 0.2 ohms
    pin6 2.3k ohms
    pin7= inf
    pin8 = 2.1k ohms

    ATM Pin 14 to ground = 2.3K which is = to opto pin 6 reading 
    ATM pin 14 to opto pin 6 = 0.6 ohms
    check continuity midi in pin 2 on board to opto pin 2 = 220 ohms as expected
    continuity midi in pin 1 on board to pin 3 = 0.4 ohms 
    continuity between midi in pins 1 and 2 with  no chip installed = inf ohms 
    I am using the I/O bpard so the signals from pins 4 and 5 on the MIDI in socket should be correct and I installed the bridge wires with no crossing per the builder guide, 
    So then lets look for odd voltages 
    opto chip out, power on, no MIDI signal
    pin1 = 0 volts
    pin2= 0 volts
    pin3= 0 volts
    pin4= 0 volts
    pin5 = 0 volts
    pin6 - 5.0 volts 
    pin7= 0 volts
    pin8 = 5.0 volts

    with opto chip in power on , no MIDI signals
    pin1 = 0 volts
    pin2= 0 volts
    pin3= 0 volts
    pin4= 0 volts
    pin5 = 0 volts
    pin6 - 5.0 volts 
    pin7= fluctuates between -.12 and -.66 volts ( is this correct??) 
    pin8 = 5.0 volts

    ATM pin 14 power on no midi signal  = 5.0 volts
    ATM pin 40 power on = 2.55 volts
    ATM pin 39 power on = 5.0 volts 

    check continuity across diode 1 
    with probes 1 way = 2.3M ohms
    with probes reversed = inf ohms

    Is there anything else I can check????  I am so close to done I can feel it but this no MIDI hassle has me up at night trying to figure it out, the fantasy was build in a day and party, but now its 3-4 days of WTF....thanks for any insights
  • Let me pull the top off my unit and get it on the bench and I'll eyeball your numbers.  Sorry this has been such a bear, but there's no way you won't figure it out at this rate.
    More soon,

  • I just re-read this, those fluctuating pin 7 voltages on opto with power on were positive .12 to .66 , those minus signs came with a cut and paste, sorry for any confusion
  • Do you have the right pull up resistor in there? 1k instead of a 10k perhaps?  Scope handy?
  • Will the real resistor value please stand up? I put in a 2.7K resistor from pin5 to pin 7 because that was the closes thing I had to the 2.4K Todd used
    I then removed it while diagnosing my MIDI problem . I;m gonna try a 10K and see what happens, you never know. 

    Elsewhere Todd said this 
    A good place to pick up ground is pin 5 of the 6N138.
    Resistor value is relatively unimportant.  Anywhere from 1k to 10k should be fine, or larger if you're strapped for parts.

    And yes I have the scope working and I trace good MIDI signal from the MIDI in jack up to pin 2 and 3 of the opto, but nothing seems to come out of pin 6 and as above I think I have pretty well tested for shorts and stray voltages pretty conclusively , maybe I should reload the firmware?  That should have nothing to do with MIDI between the opto (pin 6) and the ATM pin 14..but I'm running out of ideas...staring at the board under a magnifying glass doesn't fix it wither, but lord knows I've done a lot of that looking for a problem...... any ideas or suggestions will be greatly appreciated. 
  • if you have it on the opto out but not on the ATM in, there must be a break somewhere. Check for continuity between the OPTO PIN and the solder pad on the bottom, maybe it doesn't make good contact. Same with the ATM.
  • @rosch 

    I socketed all my ICs, that way I can swap them as needed ,  I have continuity from the top of the opto socket pin 6 to the pin on the ATM, and with the IC seated form the pin6 amd it is close to zero ohms,  0.3 ohms which is the resistance in my multimeter there is no break. I;m going to strt a new thread and see what pops up, i.e. how many folks have built it and got good MIDI play performance....the physicality of my box is good, no shorts, no stray voltage, but no MIDI play either.....somewhat frustrating !!
  • I just saw this in the operator's guide 

    STORE DEFAULT  RECORD NOTE is detailed above. It will command WTPA to record samples at the clock value corresponding to the last NOTE ON message it got, and save this value to permanent memory. A higher pitch note makes for cleaner samples by default, and vice versa.

    Is there any way to clear that value save sending a CC23??  I'm wondering if that might be a source of the problem I'm having. I never consciously set that CC value, but then who know. 
  • edited February 2015
    You should be seeing the same thing on the output of the opto as the input (square pulses), if they look rounded off instead of sharp, the uC might not be registering them (i've seen in happen with fairchild optos) but if you are getting nothing out of it, then I would start by replacing it.  I dont know what it is about 6n138s but with every project that uses them, there is always someone who has this issue (it's been me before, in my case I switched to a Vishay part from the fairchild and it was solved).  Personally, I stick with 6N137s with a 10K pull up and dont ever have issues with any brand part.  I've gone through 300 lite on parts without a single problem over the last 2 years and u can drive them with 3.3v or 5v midi devices and they just work
  • @altitude is right about seeing a waveform. You should see something. The "rounded over" waveform is probably a function of a missing emitter resistor in the first transistor in the darlington, which I posted about elsewhere and which isn't your problem (Probably).

    Try this. It sounds like you have some 6n138s lying around. Build a 6n138 circuit on a perfboard or breadboard and wire it to a stand alone midi jack. Verify you get output from it. Then desocket your original opto, and tie your breadboard circuit to WTPA2. This ought to tell you exactly where your problem is, and it doesn't take many parts.

    FWIW did you try reversing the wires on the midi in jack? Just curious.

    Let me know how it goes and good luck.

  • Well I built that 6n138 circuit on a breadboard and what do you know, the first time still nada on Pin 6 so I figured what the hell , swap the the 6n138 with another new one and sure as shootin I got the pin 6 signal, so I put that new opto on the board and it works, now the mystery is how can 4 out of 5 optos be bad????  go figure ...say a prayer that the one in there now doesn't fry some how advice to anyone else  who has wired it up properly and if you get new MIDI , swap the opto chip before you spend hours trying to figure it out.  Thanks to all for your help ...time to put it in the case and party.

    Here's a pic of the outboard circuit just for fun 

Sign In or Register to comment.