Card reader mode - no response

Hello party people

I'm a new and semi proud builder of a wpta2, and while most things are going well, some things aren't. Mostly little things that I'm sure a group head scratch can sort out quickly.

So here goes number 1. I press both shift buttons expecting to go into card mode and I see nothing at all different. No extra flashing lights or anything. Saving doesn't seem to work. Can't really confirm loading until I've saved, but after inserting micro cf card, managed to be recognised as unformatted and proceeded with formatting process successfully. Thought maybe shift 2 button was a dud so swapped it out with no change.

Just so you know what is working, my wtpa2 samples, plays audio and mostly behaves as expected, but can't get midi working and half speed on bank 2 is no go. A few things I don't get about sample start, finish, window but I'll post about these separately so things are a bit organised.

Any ideas where to next? Admittedly I'm a bit of a newb when it comes to troubleshooting circuits. I have a decent multimeter but no scope which hopefully won't be a major drama.

Any suggestions appreciated and many thanks in advance!

Comments

  • I had MIDI problems at first  ....see my posts on that .... it turned out that the opto-isolator chip was bad and it took 3 swapouts before I got one that worked. I socketed ALL my ICs so swaps were painless, you can test MIDI fail with multimeter, check for voltage on the pin in and then pin out or at the atmega pin where MIDI goes in, if you have voltage on opto in but none going out then, swap the chip , if you get a success then your problem lies elsewhere

    I can't help much with other issues... have you tried reloading the firmware? Check with Todd on that first.

    Does CV in work? 
  • Thanks bcomnes. Yep I noticed your midi post and have already swapped out the opto isolator a couple of times to try and get it going. I'll check pin voltages and get back to you.

    Firmware an interesting idea, haven't hooked up cv yet but will give it a try and report back.
  • Well haven't gotten anywhere with the card reader, but have a few pin voltages for the 6n138:
    Pin 1: 0
    Pin 2: 0
    Pin 3: 0
    Pin 4: 0
    Pin 5: 0
    Pin 6: 5v
    Pin 7: 0
    Pin 8: 5v

    also ATM pin 14 is 5v

    These all look pretty similar to your post bcomnes. I also ran midi in and tested voltage at pin 2 (the input, yea?) and got something where it would start at about 0.5v and reduce down to 0.1v or so, which I'm guessing would make a lot more sense on a scope. I'm thinking this is midi data going in, but pin 6 still reads 5v. This is my 3rd 6n138 I've tried, so before I head back to the shop and waste more money, can you tell me if this looks like the issue? Anything else I should look at?
  • On the card reader, I downloaded the sample packer and popped an aiff on my card, but get no joy when trying to load it in or play current sd sample. There's only 1 sample on the card, which script told me loaded into slot 0. Not really sure how to choose slot 0 but thought it'd be default. Any ideas on this one?

  • MIDI diagnostic 

    try the ghettoscope (look it up on this site on pins 2 and 3 of the opto  to ground -that's MIDI IN , better than a multimeter which is just voltage level , be sure to send MIDI clock so you get about 96 hertz which you should be able to hear

    then try opto  pin6 to ground with ghetto scope , that's MIDI out from the chip on its way to the ATMEGA , you get 5v there because it is riding on top of the V+ - see the schematic

    also check continuity from opto pin 6 to atmega pin 14 

    and then try  pin 14 with ghettoscope

    if MIDI is going in  at pin 14 its not anyhtiong to do with the opto chip 


  • Haha yep, saw the ghettoscope, will get onto it and report back. Thanks @bcomnes, might get this sorted yet!

  • Hey!
    Are you sure you're pressing the right button combo to enter SD mode? IIRC you need to press both shift keys AND another button.

    If you're sure then make sure your SD reader is soldered down right. You can test by sticking a non WTPA formatted sd card in the slot. If WTPA stops and asks you to format, your SD card reader is working.

    Remember WTPA2 only handles SD and not SDHC so yr card has to be 2gb or less. I don't think any < 2gb cards are sdhc but the card will probably say.

    Re midi and bank2, I'm at a bizarre white wedding right now and I look like Andrew WK. It's embarrassing. I'll check that stuff when I get home. Sounds like the bank2 thing is a bug.

    Party till you puke,
    TB
  • Thanks Todd, sorry to mess with your social life!

    I'm officially a moron, yep not pressing enough buttons. At least I'm a happy moron, if bank B half speed is a bug then I've really only got one issue left to sort.

  • @bcomnes you're a legend, thanks for the step by step.

    Can hear midi in on pin 2&3, so it seems to be getting that far, but nothing on pin 6. I'm guessing this means a fried 6n138, yes?

    Since I've tried 3 with no luck so far, any tips to getting one working? I've socketed it, so no trouble swapping it out, but do I need to source a different brand to my local crappy parts supplier's stock, or is there some kind of trick to getting it in and working?
  • You should be able to hear MIDI on pin 6.

    If you've tried three optos already it's not likely the opto.

    Make sure D1, the 1N4004 protection diode on the input to the opto, is the correct polarity.  If it were backwards, you would still hear MIDI on the input but the voltage would not be high enough to turn on the opto.
    The cathode band should point "up" toward the top of the PCB.

    While you're working on that stuff, solder a resistor from pin 5 to pin 7 per here:

    Even without that pull down, you should still hear MIDI on pin 6.  Also, your ghetto scope may work strangely on pin 6 of the opto since it's biased to 5v.  I'd guess you should hear something, but when in doubt capacitively couple your ghetto scope as seen in the post on "troubleshooting".
  • Hey Todd,
    Yep, resistor is between pin 5&7 and diode polarity is correct, any other ideas?
  • I'd also check polarity of the MIDI jack itself.  Make sure pins 4 and 5 aren't reversed.  Reverse them anyway just to check.
    Make sure the output pin of the opto isn't shorted to something else (like another pin or the 5v rail).
    Make sure the opto isn't upside down.
    Make sure the collector resistor on the MCU side of the opto is the correct value.  You can check this and the shorts with a multimeter.

    Getting NO signal at all there isn't right.  If you get totally stuck, build the MIDI input circuit on a breadboard or perfboard and see if you get signal at the output then.
  • Found it!! Pulled the chip and reseated it and presto, working! Thanks to y'all for your help. Now it's working I can appreciate how much fun this is to play with! Great work on this Todd, amazing machine!
  • Glad you got it working!  Have fun and thanks for the kind words.
Sign In or Register to comment.