WTPA recording issue

so this is about the 3rd WTPA i've made, rack mounted and should actually work, because it did before, unassembled. but it won't now.
it seems weird:
the controller actually works, ie the tact switches toggle the proper leds, all like intended. it also does record, but no audio at this point. there's just an audible click
at the beginning of the sample which is usually not there when everything's fine.
i had a similar click in a previous build when i had some noise picked up by the shielded audio cables that i first had going right along the MCU. that had been fixed by moving the audio cables to outside of the circuit in that build.

now this is more weird. playback obviously works. i can tell that by what is done to the click at he beginning. i can do everything with it, granularity, bitreduction, output recombination, back and halftime.
all pots work too. audio through works without problems. i can also reduce gain and master volume, just no effect with the DAC.
also strange: realtime doesn't work. but if i press S5+S4+S2 which should be something in edit mode it seems to switch in some kind of realtime:
the rec overdub and play leds all light up (in RLTM usually all 3 data leds do that) and depending on how deep my bit reduction (e.g.) was set it produces wild feedbacks. the set FX seems to work though. as if it were realtime. the clock VCO pots also have a weird impact on the sound.
then after pressing S0 or S1 or S2 again it goes back to normal mode.
i think i'd better do a lil video to show what happens. maybe later.

well the board totally worked before. the wiring must be ok because all the switches work their corresponding lights and functions.
also rec/overdub go in rec/overd mode and when hit again change to play. also after a while of writing zeroes the out of ram led indicates the sram has been written.
pls don't tell me it's the sram haha

might it be just wild magnetic fields from my cheapo block transformer that i have sitting right behind it ?
unfortunately i have soldered all ICs directly to the pcb so i can't swap easily. but that at least tells that i haven't reversed some in the meantime or something.
the only thing i changed with the iron after it had worked was desoldering the audio headers and changing to shielded cable, also power header. nothing else.
gonna make a video tonight.
thanks for reading, guys.

Comments

  • http://farm8.staticflickr.com/7167/6684641049_5282f5c144_z.jpg
    http://farm8.staticflickr.com/7174/6684639317_5ea09482b0_z.jpg
    http://farm8.staticflickr.com/7030/6684640333_9ec2bbbca1_z.jpg
  • it smells like: 1) output signal to ground, somewhere, or, 2) oh those crazy hominids, are the jack cables reversed, I'm just saying because after checking twice on my shruthi-xt I reversed my midi jack connections right after I was double sure they were on the right jacks for the labelled case. If 1 then take it out of the case in case teh case is grounding the outputs and see if it runs correctly. Copper sheet to box encase the transformer? (did that on my clavinet.) Break the audio shield itself at one end? Pretty lame sggestions I know.
  • Starscream: I live to serve you, Lord Megatron!
    Megatron: Where is the Cube?
    Starscream: The humans have taken it!
    Megatron: [growls] You failed me yet again, Starscream. GET THEM!
  • Hey!
    If you're getting audio through, and gain, THRU and master controls all work, and you suspect wiring, then I'd check VR4, the DAC output level control.
    It's also worth putting the device into test mode and seeing if you can get a sawtooth out.
    TB
Sign In or Register to comment.