LED's not all working; sampling very distorted

Hey,

I'm on my second WTPA board; Todd has been very helpful and gracious so far; maybe someone can help me now!

I had my WTPA built and working for 24 hours (I think working 100% - sampling was a bit noisy, but I think OK). Last night as I was desoldering the Midi Connector (with the power still on!! It's my own fault) I think I shorted something, there was much flickering of LEDs, and now some things don't work.

I've read through most of the forum; here's my application of what I have read and tried:

- When I turn it on LED 2 flashes as it should
- The input amplifier, throughput and output amplifier all behave as expected
- The relaxation oscillator is working as expected (ghetto oscilloscope one of the many things I've learned!)

- When I hit record, LED 0 FAILS to light [the LED is def still working]
- When I hit record again, LED 2 lights and it begins playback - but the playback is a very distorted, digital sound. The sound bears some relation to the input (e.g. no input, quieter sample playback) but it's not recognisable.
- When I hit overdub, LED 1 lights, and I hear very distorted sound
- Start / stop playback works as expected
- LED 3 and LED 4 are blown, I'll need to replace them
- LED 5 lights when I turn the parameter control fully clockwise, but not LED's 6 and 7. LED 5-7 are all still working
- the SRAM chip is HOT! like, too hot to hold your finger on.

I'm sure it's not good news; but can anyone point me down a troubleshooting path?

Comments

  • edited April 2011
    i'm no expert at all but i've vivisected circuits too while troubleshooting, albeit not like wtpa with a microcontroller. it's not recommended actually but it worked fine for me when searching for bad solder joints (as you can hear the sound change).
    maybe you have bridged something (as you already estimated) and the bridge is still there?
  • Hmm. You've done a lot of homework which is good, but those symptoms are bad.

    So, if you're sure LED0 works (like you've diode checked the LED when the device is off) but does not light, AND you have distorted audio, then the there's most likely a line on your bus that's stuck or shorted to something else. See the schematic for reference. The same line on the bus that controls LED0 also runs to the DAC, and it's also a data and address line to the RAM, so probably just about all your audio to be screwy. If you're also sure about LEDs 6 and 7, then you have more than one stuck.

    You need to figure out if and why those nodes are stuck. Unfortunately, if the RAM is _that_ hot, it's likely to be the RAM. But you might be lucky. If you've socketed your chips you can selectively pull your different latches and see if a line starts toggling again. Easiest way to do this is with a scope, since you won't be able to use your ears when the DAC latch is pulled, or your eyes when the LED latch is pulled, etc etc. But with the ghetto scope and some deduction, you can probably figure it out.

    Try the LED latch first. If it's still bad, pull ALL your latches and then see if the RAM still gets hot (and see if the lines toggle if you can -- LED0/Latch0 is pin 1 of the MCU).
    A solder bridge could cause this problem (best case and most frequent, but unlikely if multiple lines are bad)
    Or a bad latch (not too hard to fix)
    Or a bad MCU (not great)
    Or screwed up RAM (annoying to fix).

    Sorry you're having trouble. Let us know what you find!
    Best of luck,
    TB
  • Thanks Todd, that's really thorough. I'll dive into it in the next couple of days.

    "If you've socketed your chips" ........ darn it!! I soldered some of the latches in directly. Grr.

    A
  • Yeah, I have to admit I do that too. But I have a fancy desoldering tool. Generally sockets are good for testing or when you think something might need to get changed, and when that's not the case they're electrically imperfect and expensive.
    So, on kits, I include sockets. It's either that or a http://www.howardelectronics.com/den-on/sc7000.html and the sockets are cheaper :-)

    Best of luck,
    TB
  • I'm waiting for a few new latch chips so I can try replacements. I'll let you know progress...
  • Good luck!
  • OK. I've been busy!

    I've replaced IC8; I've also replaced the RAM (MAN what a crazy job that was), but it's still not working. I will try replacing the other latches but because I'm literally cutting them out with a knife to remove them I wanted to check in and see if there was any wisdom.

    Sampled audio is still totally distorted; but all other functions seem to be working OK (e.g., I can hear the distorted sound reverse when I press S5/S4) That makes me hopeful that the MCU is ok - right?

    LED5 is failing to light when it should, but it lights when LED4 lights - but there's definately no short between them. Tracing back the LED5 input to pin 15 of IC8, it's not toggling when it should - but the chip is replaced and so should be fine.

    Is this pointing to one of the other latches being broke? If so, which one - that would save me a bunch of manual labour...
  • Good work so far.
    There's no guarantee in the above that it isn't the MCU. However, if I'm reading you right it sounds like or a short on the bus side before the latches.
    If one LED toggles along with another one _always_, that's a good sign there's a short between those two lines. They are probably physically adjacent and could be shorted together. IE, if LED4 and LED5 always toggle together, check the lines going to the latch -- these bus lines go everywhere and so could cause distorted audio as well.

    These are probably most likely to be shorted at the SRAM (cause that's where the lines are closest and the solder trickiest) but it could be anywhere.

    I'd figure this out before you cut anything else out.

    Keep it up and good luck,
    TB
  • Thanks Todd.

    Working now! Really appreciate your help. I rather 'brute forced' the solution by building a whole new WTPA on the other board you had kindly sent, and then checking the MCU worked on both. So I now have two working WTPAs!

    I traced shorts across the bus on the original board and discovered there was a short between two pins of the latch IC8; when that was cleared up it was fine.

    The whole journey has been a lot of fun. Things that I found which might be helpful to others:

    - if you break a couple of tracks whilst soldering the SRAM, with a pair of tweezers it's possible to individually solder pins to the nearest through hole connector using fine enamelled wire. This saved another board from destruction.

    - removing SRAM is really tricky; I found using this method the best - http://www.youtube.com/watch?v=C0vsdBFMSRQ - but instead of threading the wire underneath the RAM and pulling out, I found that pulling the wire from outside to underneath the RAM worked best.

    - SRAM can take one hell of a beating and still function OK in the end

    - when soldering new SRAM in, whacking a lot of flux around the SRAM really makes an amazing difference to how easily the solder flows into the right places

    - I used a usbtinyisp avr kit programmer to programme the new avr. You must jumper the resistors R4 and R7 on the kit to programme an AVR directly on the WTPA board

    - you don't need to download xcode to install avrdude on OS X, you can get the complete package here http://www.obdev.at/products/crosspack/index.html

    - using avrdude on OSX the two commands required to programme the avr from scratch are:

    avrdude -c usbtiny -p m164p -u -U efuse:w:0xFC:m -U hfuse:w:0xD9:m -U lfuse:w:0xF7:m

    to set the fuses, and then

    avrdude -c usbtiny -p m164p -U flash:w:/Users/[YOUR USERNAME HERE]/Desktop/WheresThePartyAt/WTPA.hex

    with the WTPA files downloaded to your desktop.

    If you don't do the first command, the WTPA behaves very strangely - only very slowly responding to your commands (I guess because it is running from a slower internal clock-speed)

    Thanks again Todd for the support. I'll keep an eye out for WTPA2.
  • Excellent work. And good points too with respect to repair. The SRAM is actually a "J-Lead" package which is stood off the PCB a little more than a normal SOIC, so that enameled wire method probably works even a hair easier. Gauge of the enameled wire probably matters too. Good call with the flux, and also with repairing the messed up SMT pads. Also, way to dig in the source to find the AVRDUDE commands.

    Again, great troubleshooting job and thanks for posting your results here to help everybody else. Happy sampling!
    TB
  • congrats!
    yeah the SRAM is really heat resistent! i worried about that too. but works great.
    and great to see you got your problem solved.
  • cheers rosch. it's nice to be a part of this wtpa thing...
  • I thought that desolder gun was $39.50 and almost clawed teh screen, ooops move the deci.mal never mind, sigh
Sign In or Register to comment.