A little help please, my WTPA is not alive yet.

SO I finished soldering and plugged her up, and I get 2 led's on. I can hear my audio, and the knobs are working. I can not use any of the buttons, and my power led is not on at all. I went back to all my soldering points and assured connectivity. Any input is greatly appreciated.

Comments

  • polarity on the LEDs correct?
  • Cool that you got it together! So yeah, if your analog section works, it means you're getting power to the PCB. I'd check not only the polarity on the LEDs, but on ALL the diodes on the board (the black things with the silver bands) and while you're at it, the electrolytic caps, too. The buttons not doing anything may be a different problem, but one thing at a time. Once the power LED turns on when power is applied, that's a good start.

    If you have a multimeter, you should see 5v across the RegVcc header. You should also see either 5v or somewhere around 2v at the exposed end of r6 (the resistor on the power LED) depending on which end you probe.

    Hope this helps and good luck!
    TB
  • Hi there! Didn't realize I could actually have input on this forum until very recently. Anywho, I built my WTPA, but it won't turn on. When I plug it in and test I can see that there's power in all the right places, but no LEDs come on and I get no audio. When I first tried to turn it on I noticed I had accidentally put one LED in backwards, so I fixed it, but still nothing. Any ideas guys?
  • Well, the first thing to do would be to start a new thread :-)
    But that having been said, what are "the right places"? Can you see 5v across the power and ground pins of the quad opamp?
    TB
Sign In or Register to comment.